Forums

ericc is dreaming :: Forums :: Support :: Windows
 
<< Sujet précédent | Sujet suivant >>
Pb de wifi
Aller à la page   <<      
Modérateurs:ericc, toxxic, mich_belge
Auteur Message
ericc
dim. sept. 16 2012, 20:10
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2277
toxxic a écrit ...
Juste cette réponse me parait "chelou"


Ok c'est pourtant simple.

Imaginons que tu as un portable avec un Ethernet et un Wifi, tout les deux configuré en DHCP.
Tu les connecte sur le même router qui fait office de serveur DHCP mais avec 1 seul range.

Dès lors tu te retrouve avec une configuration comme suit:
  1. ericc@netbook:~$ ifconfig
  2. eth0      Link encap:Ethernet  HWaddr 00:23:5a:9c:79:11  
  3.           inet addr:192.168.28.5  Bcast:192.168.28.255  Mask:255.255.255.0
  4.           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
  5.  
  6. lo        Link encap:Local Loopback  
  7.           inet addr:127.0.0.1  Mask:255.0.0.0
  8.           UP LOOPBACK RUNNING  MTU:16436  Metric:1
  9.  
  10. wlan0     Link encap:Ethernet  HWaddr 00:24:2c:90:54:14  
  11.           inet addr:192.168.28.7  Bcast:192.168.28.255  Mask:255.255.255.0
  12.           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

(j'ai supprimé quelques lignes pour plus de clarté)
Comme tu le vois, les 2 adresses IP sont dans le même range et pointent vers la même gateway (passerelle).
Regardons maintenant la table de routage :
  1. ericc@netbook:~$ route
  2. Kernel IP routing table
  3. Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
  4. default         192.168.28.251  0.0.0.0         UG    0      0        0 eth0
  5. link-local      *               255.255.0.0     U     1000   0        0 eth0
  6. 192.168.28.0    *               255.255.255.0   U     1      0        0 eth0
  7. 192.168.28.0    *               255.255.255.0   U     2      0        0 wlan0
  8.  

Donc la gateway est 192.168.28.251, mais les 2 interfaces offre une solution (192.168.28.0/255.255.255.0)
Dans ce cas de figure, il y a 3 solutions:
  • ° rien ne fonctionne
  • ° une des deux interfaces est ignoré
  • ° si les deux coté (le PC et le routeur) sont de bonne volonté, les deux interfaces fonctionnent et le trafic est dispatché entre elles, additionnant les bandes passantes


A priori,si je regarde la table de routage, eth0 devrait être l'interface par défaut ... mais :
  1. ericc@netbook:~$ ping 192.168.28.251
  2. PING 192.168.28.251 (192.168.28.251) 56(84) bytes of data.
  3. ping: sendmsg: Operation not permitted
  4. ping: sendmsg: Operation not permitted
  5. ping: sendmsg: Operation not permitted
  6. ^C
  7. --- 192.168.28.251 ping statistics ---
  8. 3 packets transmitted, 0 received, 100% packet loss, time 1999ms

pas de bol ! rien ne fonctionne !!
A signalé, que je peux pinger l'adresse IP de chaque interface sans soucis !!


Maintenant, je désactive une des deux:
  1. ericc@netbook:~$ ifconfig
  2. eth0      Link encap:Ethernet  HWaddr 00:23:5a:9c:79:11  
  3.           inet addr:192.168.28.5  Bcast:192.168.28.255  Mask:255.255.255.0
  4.           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
  5.  
  6. lo        Link encap:Local Loopback  
  7.           inet addr:127.0.0.1  Mask:255.0.0.0
  8.           UP LOOPBACK RUNNING  MTU:16436  Metric:1
  9.  
  10.  
  11. wlan0     Link encap:Ethernet  HWaddr 00:24:2c:90:54:14  
  12.           UP BROADCAST MULTICAST  MTU:1500  Metric:1


  1. ericc@netbook:~$ route
  2. Kernel IP routing table
  3. Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
  4. default         192.168.28.251  0.0.0.0         UG    0      0        0 eth0
  5. link-local      *               255.255.0.0     U     1000   0        0 eth0
  6. 192.168.28.0    *               255.255.255.0   U     1      0        0 eth0

le wifi n'est plus connecté et au miracle :
  1. ericc@netbook:~$ ping 192.168.28.251
  2. PING 192.168.28.251 (192.168.28.251) 56(84) bytes of data.
  3. 64 bytes from 192.168.28.251: icmp_req=1 ttl=64 time=2.57 ms
  4. 64 bytes from 192.168.28.251: icmp_req=2 ttl=64 time=0.974 ms
  5. 64 bytes from 192.168.28.251: icmp_req=3 ttl=64 time=0.936 ms
  6. ^C
  7. --- 192.168.28.251 ping statistics ---
  8. 3 packets transmitted, 3 received, 0% packet loss, time 2003ms
  9. rtt min/avg/max/mdev = 0.936/1.496/2.578/0.765 ms

A signaler que j'ai du stopper les 2 interfaces et redémarrer seulement eth0 avant que cela marche.
C'est un exemple avec eth0, mais c'est exactement la même chose avec wlan0

Mon netbook est installé avec un Ubuntu classique, pas de surprise ni de suspicion sur une configuration bizarre d'une obscure distro.

Pourquoi cela ne fonctionne pas ?
Bonne question !
Je dois avouer que je ne me suis jamais poser plus de question que cela.
Pour moi, le fait que les 2 interfaces se retrouvent dans le même range et la même gateway, pose des problèmes au kernel qui se prend les pieds dans le tapis.
Du fait que tout refonctionne correctement dès que je désactive une des deux interfaces me suffit (lazy attitude)


ericc
Retour en haut
Site Internet
misterxxc
lun. sept. 17 2012, 07:05
Membre enregistré #38
Inscrit(e) le: mar. janv. 16 2007, 11:28
Messages: 156
Va pour le cas 2 :

J'ai pensé à l'ampérage des ports USB eric donc j'ai testé tous les ports sans succès, sur mon dell lattitude E6400 il y en a 4 dont un qui est mixte USB / e sata.
Je n'ai pas la notice je vais regarder si je trouve les infos.

Pour la conso de la clé wifi qui est une netgear WNA1100 je n'ai rien dans le bundle.

Je vais regarder via le support technique netgear on verra ce qu'ils vont dire je vous tiens au jus.

Bonne journée.
Retour en haut
misterxxc
mar. sept. 18 2012, 12:40
Membre enregistré #38
Inscrit(e) le: mar. janv. 16 2007, 11:28
Messages: 156
Pour retour fonctionnement de la clé sur mon laptop toshiba pas de soucis mais malheureusement je n'ai pas le résulatt obtenu en terme de réception signal.
Retour en haut
Aller à la page   <<       

Allez à:     Retour en haut

Fil d’informations pour ce sujet: RSS 0.92 Fil d’informations pour ce sujet: RSS 2.0 Fil d’informations pour ce sujet: RDF
Powered by e107 Forum System
Temps d'exécution:0.1818s, dont0.0155de celui des requêtes.Requêtes BdD:28. Utilisation mémoire:1,474ko