Forums

ericc is dreaming :: Forums :: Support :: Linux
 
<< Sujet précédent | Sujet suivant >>
Linux Mint Debian Edition (LMDE) Update7
Aller à la page   <<      
Modérateurs:ericc, toxxic, mich_belge
Auteur Message
ericc
lun. oct. 07 2013, 13:38
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2277
toxxic a écrit ...
Pour combien de temps ? Et a quand ensuite les prochaines mises a jour ?
Bon tu devrais retrouver (Normalement...) ton environnement fétiche c'est déjà ça ! Mais... je suis moins optimiste que toi ne serait-ce pour l'avenir de LMDE qui n'apporte plus rien comparer a de très nombreuses "distros" proposant du "testing" prè-configurer , "distros" qui elles assument leur choix et le revendique sans se foutre de la gueule de leurs utilisateurs (gel du noyau hors mises a jour sécu) et proposant des logs (en version stable) plus a jour !

Je ne suis pas sur de te comprendre là ?!
Il n'est pas question que je réinstalle LMDE !!
J'attend la sortie de Gnome-Ubuntu 13.10 ...
Fini LMDE, à la poubelle !! Ils n'ont pas tenus leurs engagements (moraux!) je passe à autre chose


toxxic a écrit ...
LMDE avait l’avantage d'être très stable , seulement... l'UP7 a changer la donne et une mise a jour majeure une fois par an bah 70% ont nécessité de réinstaller

Moi j'installe ... autre chose !


toxxic a écrit ...
La section LMDE du forum Mint.fr n'a jamais été aussi morte , pas qu'il n'y a pas de soucis c'est juste qu'ils se sont tous tirés ailleurs

Pareil
Sur le forum officiel, dans la section LMDE, c'est quasiment impossible d'obtenir un renseignement fiable.
Il n'y avait que "zero-zero" mais il est parti en tant que fondateur de Solyd (devine pourquoi !)
Sinon , c'est l'IRC mais je n'aime pas franchement


ericc
Retour en haut
Site Internet
toxxic
lun. oct. 07 2013, 14:11
toxxic

Membre enregistré #3
Inscrit(e) le: dim. oct. 01 2006, 08:54
Messages: 1425
a écrit ...
Je ne suis pas sur de te comprendre là ?!
Il n'est pas question que je réinstalle LMDE !!
J'attend la sortie de Gnome-Ubuntu 13.10 ...

Euh... J'ai pas cliqué sur le 1er lien (le second oui) et comme le titre du sujet ici se rapporte a LMDE UP7 et que textuellement tu ne fais pas allusion a Ubuntu je me suis mépris
toutes mes confuses
Retour en haut
ericc
dim. oct. 20 2013, 11:28
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2277
Donc, Ubuntu 13.10 est sortie officiellement Jeudi.
Dans un premier temps, je pensais attendre quelques jours, histoire que les premières personnes installent et remontent les bugs.
Vendredi soir, j'avais un peu de temps et n'ayant rien vu de significatif sur le forum de Ubuntu, j'ai décidé de me lancer (cela faisait quasiment 3 semaines que je travaillais sur un système bancal d'où une certaine impatience)

Installation sans soucis, j'avais déjà sauvegarder mes fichiers personnel sur la partition de Windows7 (en NTFS).
Après environ 20min, y compris une mise à jour et 5min pour réinstaller et reconfigurer le driver vidéo ATI, tout était en place !!

Me revoici sous Gnome3 (aka: Gnome-shell)

Comme j'avais aussi sauvegarder certain répertoire/fichier de configuration comme .mozilla , quand je les ai restaurer, j'ai retrouver mes applications dans l'état ou je les avais laissé. Même Firefox m'a ré-ouvert toutes les pages web comme précédemment ...

Je reconfigure 'conky', un peu de tâtonnement pour rétablir la transparence (les paramètres sont différents suivant le window manager) et c'est reparti

Je commence à restaurer mes fichiers à partir du NTFS ... et là, panique !! Je vois l'indicateur de mémoire dans conky qui grimpe au plafond !!
J'ai actuellement environ 6Go de RAM et il m'annonce "full à 98%"

J'attend que la copie se termine, mais l'occupation mémoire reste très haute. Le bizarre dans l'histoire, c'est conky m'affiche aussi le top 3 des applications consommant le plus de RAM et que Firefox (qui est le 1er) ne consomme que 5% !!!
Je vérifie dans "top" et dans le "system monitor", aucun ne me montre une application consommant une quantité excessive de RAM ...
Je ferme toutes les applications, la consommation mémoire reste haute ... de plus en plus bizarre.

Je reboot, enfin la mémoire revient à un niveau habituel. Je laisse tourné sans rien faire, pas d'augmentation non plus.
J'en viens à douter du driver NTFS, en effet c'est lors de la copie de fichier que la consommation augmente ...
Mais en déplaçant des fichiers d'un répertoire vers un autre (sans utiliser le NTFS donc) je constate le même soucis ...

Finalement ce matin, après quelques recherches, j'ai fini par tomber sur cette page :
Help! Linux ate my RAM (Au secours, Linux mange ma RAM)
qui confirme mes soupçons.
Durant la copie (comme pour toutes opérations impliquant des accès disques) Linux utilise une partie de la mémoire disponible pour accélérer les opérations ... et ne la restitue pas.
La mémoire est indiqué "occupée" mais en fait elle est tout à fait libre si une application en a besoin.
  1. ericc@predator:~/bin$ free -h
  2.              total       used       free     shared    buffers     cached
  3. Mem:          5.8G       5.7G       160M         0B       1.5G       3.0G
  4. -/+ buffers/cache:       1.1G       4.7G
  5. Swap:          17G         0B        17G

Comme le montre la commande "free" (j'ai rien compris), en mémoire libre, il me reste 160M sur 5.8G. C'est le chiffre que voit conky.
Mais le chiffre réel se trouve sur la 2eme ligne : 4.7G de libre (ouf, je respire)
On peux aussi se rassurer car l'utilisation de la swap est à 0 ... si la mémoire était réellement utilisé, la swap serait sollicitée

Pour libérer les buffers et le cache, il faut taper la commande suivante.
  1. echo 3 | sudo tee /proc/sys/vm/drop_caches
j'en ai fait un script vite fait bien fait, histoire de l'avoir toujours sous la main

Notez bien que cela n'est pas nécessaire ... le système, lui, pour lancer les applications ne voit que le chiffre de la deuxième ligne !

Il faut juste que je trouve un moyen de dire à conky de prendre en compte cette ligne, histoire de ne pas attraper une crise cardiaque à chaque fois que je regarde le graphe.
D'ailleurs, conky n'aurait pas été là, je n'aurais même pas noté que la RAM montait à 98%

ericc
Retour en haut
Site Internet
toxxic
dim. oct. 20 2013, 17:19
toxxic

Membre enregistré #3
Inscrit(e) le: dim. oct. 01 2006, 08:54
Messages: 1425
Merci pour la commande
direction mon dossier "script"
Retour en haut
ericc
dim. oct. 20 2013, 17:46
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2277
Petite correction/précision de la commande en question, trouvé sur un autre site :
  1. #!/bin/bash
  2. sync; echo 3 | sudo tee /proc/sys/vm/drop_caches
A priori, la commande "sync" permet de forcer les buffers à être écrit sur le disque ... avant de les purger, évitant une perte de données malencontreuse

ericc
Retour en haut
Site Internet
Aller à la page   <<       

Allez à:     Retour en haut

Fil d’informations pour ce sujet: RSS 0.92 Fil d’informations pour ce sujet: RSS 2.0 Fil d’informations pour ce sujet: RDF
Powered by e107 Forum System
Temps d'exécution:0.1421s, dont0.0141de celui des requêtes.Requêtes BdD:28. Utilisation mémoire:1,527ko