Forums

ericc is dreaming :: Forums :: Support :: Linux
 
<< Sujet précédent | Sujet suivant >>
compilation de vlc ...
Modérateurs:ericc, toxxic, mich_belge
Auteur Message
marco123
sam. déc. 07 2013, 17:56
marco123
Membre enregistré #15
Inscrit(e) le: mer. oct. 04 2006, 16:30
Messages: 543
Comme vous savez, vlc n'est plus fournit directement avec le décodage mp3 / mp4a ( question de droits ! )
J'ai donc essayé de le compiler moi même ....
J'ai bien obetnu le mp3 / mp4a ....
Mais plus de live555 !
Donc, aprés avoir fouiné, j'ai trouvé un truc et j'ai eu le live555 ... oui ! yesss !
Je teste pour voir, et plus de h264 !!!! ouinnnn !
J'ai le live555 ( rtsp ), le mp3 / mp4a ... mais plus de h264 !
Et pas moyen de le remettre .... je pige plus !
Retour en haut
ericc
sam. déc. 07 2013, 18:35
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2265
marco123 a écrit ...
Comme vous savez, vlc n'est plus fournit directement avec le décodage mp3 / mp4a ( question de droits ! )

Tu es sur de cela ??
Je viens de l'installer sur Gnome Ubuntu et il joue les MP3 sans soucis ni poser de questions ...

Si je n'avais pas peur de fâcher toxx, je dirais bien "Ubuntu ruuuulllezzzz"

Sinon, quelles options tu ajoute quand tu compile VLC ?
Lors de la première compilation, tout les autres formats fonctionnaient ?

Tu es sur d'avoir toutes les librairies (en dev!!) nécessaire et utiles ?
Les versions "normale" ne suffisent pas quand tu compile, il te faut impérativement des versions "dev"

je n'ai jamais compiler VLC jusqu'ici, mais avec toutes les possibilités et dépendances, tu vas rigolé ...


ericc
Retour en haut
Site Internet
marco123
sam. déc. 07 2013, 18:46
marco123
Membre enregistré #15
Inscrit(e) le: mer. oct. 04 2006, 16:30
Messages: 543
oui, je suis sur du truc !
pour les option de compile, il te faut mettre : --enable-x264 --enable faad ......

Pour les lib, je les ai car au ./configure, quand il y en a qui manque ca te dit : pas la lib bidule, mettre --disable-bidule
Quant a compiler vlc, il n'y a pas trop de mal .
La commande ./configure te donne toutes les options que tu ajoutes ou enlèves, sans compter
celles qui sont validées par défaut et celles qui sont de-validées par défaut !
Ca limite la longueur de la ligne !
Pour moi :$*./configure --enable-xvideo --enable-live555 --enable-faad --enable-x264
ensuite make et make install .
Retour en haut
ericc
sam. déc. 07 2013, 19:39
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2265
J'ai bien peur de ne pas pouvoir t'aider plus que cela malheureusement !!
Comme déjà dit, je n'ai jamais compilé VLC et manifestement tu sais parfaitement comment visualiser le résultat de ./configure pour voir quelles librairies il te manque ...

je ne vois pas ce que je peux faire de plus ...
Tu es sur qu'il n'y a pas une option "h264" ? et si oui, qu'elle apparaît bien dans le fichier configure ?

ericc
Retour en haut
Site Internet
marco123
sam. déc. 07 2013, 21:32
marco123
Membre enregistré #15
Inscrit(e) le: mer. oct. 04 2006, 16:30
Messages: 543
oui, il y a bien c'est option elle s'appelle x264 ...
Retour en haut
toxxic
sam. déc. 07 2013, 23:28
toxxic

Membre enregistré #3
Inscrit(e) le: dim. oct. 01 2006, 08:54
Messages: 1421
je n'etais pas au courant de restrictions de codecs dans VLC dorénavant...

Et non Ricco tu ne me fâches pas , tu n'est pas obliger d'installer une distribution semi-commercial a la Ubuntu pour avoir tout les codecs chez moi VLC avale tout !

Solyd ça rox (mise a jour mensuelle aujourd'hui RAS)
Retour en haut
ericc
dim. déc. 08 2013, 10:06
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2265
Je suis quand même intrigué par cette restriction au niveau des MP3.
J'aimerais bien que tu me montre ou tu as vu cela ... ?

Je suis aller sur le site de VLC, sur la page des "features"
Input
Audio Output
et le MP3 est bien présent dans la liste comme "Native Format" en Input ET Output
Le MP4 n'est présent que en Input

Quelle version de VLC est proposé dans tes dépôts ?
Pour moi, hier, il a installé la 2.0.8
le soucis vient peut être avec la dernière version 2.1.0 ???

ericc
Retour en haut
Site Internet
toxxic
dim. déc. 08 2013, 11:46
toxxic

Membre enregistré #3
Inscrit(e) le: dim. oct. 01 2006, 08:54
Messages: 1421
Je suis en 2.1.1 et pas de soucis quel que soit le format

Ce qui se dit sur VLC en ce moment :
http://www.pcinpact.com/news/84427-vlc-2-1-1-ajoute-support-experimental-codecs-hevc-et-vp9.htm
http://iloveubuntu.net/vlc-211-released-experimental-h264-successor-hevc-support

Même question que ricco , Sur quelle version de VLC tournes tu Marco ?
Retour en haut
ericc
dim. déc. 08 2013, 12:18
ericc

Membre enregistré #1
Inscrit(e) le: ven. avril 06 2007, 20:31
Messages: 2265
Je suis aller sur le site de la version 2.1

et j'ai lu attentivement tout les changelogs depuis la version 2.0.8

et aucune trace d'un quelconque retrait du support du MP3 ...

De plus, VLC sans le support du MP3, cela perd grandement de son intérêt et je ne vois pas l'utilisateur de base Window$ recompiler un soft aussi simple que cela puisse être même pour pouvoir supporter quelque chose d'aussi fondamental que le MP3 (il installera plutôt autre chose, ce n'est pas le choix qui manque)

ericc
Retour en haut
Site Internet
 

Allez à:     Retour en haut

Fil d’informations pour ce sujet: RSS 0.92 Fil d’informations pour ce sujet: RSS 2.0 Fil d’informations pour ce sujet: RDF
Powered by e107 Forum System
Temps d'exécution:0.2331s, dont0.0156de celui des requêtes.Requêtes BdD:29. Utilisation mémoire:1,467ko